Important Security and Browser Update

As part of the continuous improvement of the security and performance of our website and other ecommerce platforms, we will be disabling support for TLS 1.0 and 1.1 encryption on 1st April 2021, which may affect how you interact with Arco. This change is required to maintain security and compliance with current industry standards and to improve load times of our websites.

The new minimum supported standard for web browsers will be TLS 1.2 which is supported by default by the following minimum versions of web browsers:

Browser Minimum Version
Internet Explorer 11
Microsoft Edge 86
Firefox 82
Google Chrome 86
Safari 13.1
Opera 71
iOS Safari 13.7
Android Browser 81


To install and use the browsers in the table above, you must be running the following minimum versions of operating systems:

Minimum Operating System Version Minimum Service Pack Revision
Windows 7 SP 1
Windows Server 2008 R2 SP 1
Windows Server 2012 R2


If you use a browser version or operating system older than those in the tables above (ie one connecting with TLS 1.0 or 1.1), you will not be permitted access to our website and other ecommerce platforms. If you already use one of the modern browsers listed in the table above, or a newer version, you will not experience any problems.

To continue using our web offerings without any issues, please ensure you're running a modern supported browser.

If you are unsure as to which version of TLS your browser supports, you can check using this TLS Version Checker, your web browser (client) must support a minimum of TLS 1.2 to check which web browser (client) your using Web Browser (client) checker.

Back

Find us on:

Arco website help desk - Need help? email: web.help@arco.co.uk © Arco Limited, Registered in England, No 133804, PO Box 21 Waverley Street, Hull HU1 2SJ.
VAT No: 166911546